15 thoughts on “A fix for Salome-Meca 2019 “Error on Save”

  1. Thanks Maxilien, this bug was a real bummer.
    Any chance you got to fix the bug with the interactive selection of GROUP_MA? There seemed to be some issue in asterstudy\gui\parameterpanel\views.py, line 2006. The structures of items in ‘names’ differs from a group to another : sometimes it has three items (name, size, occurs) but sometimes only two (name, size). It results in an error message.

    Like

    1. Hello Victor, thanks for you feedback! We don’t have time to investigate on it but since it is pure python, you can try to adapt the code and re-launch Salome. Let us know it you solve this we will be glad to integrate your contribution 🙂

      Like

      1. Maximilen,

        That is what I did. Here is the code to include at line 2006 :

        #for name, size, occurs in names:
        for grp in names:#
        if len(grp)==2:#
        name=grp[0]#
        size=grp[1]#
        occurs=1#
        else:#
        name=grp[0]#
        size=grp[1]#
        occurs=grp[2]#

        Kind of fix the problem, even if not perfect.

        Like

  2. I don’t know why, but Code-Aster and related tools hate me… I tried all my skills to run the software under Debian 8, 9, 10. Ubuntu 16.04, 18.04, Mint, VirtulaBox…. and now under Windows. The result is always the same. Something doesn’t work. Basic things like running a module.

    Upon activation of AsterStudy module I get unexpected error..

    Traceback:
    File “C:\sm-2019-w64-1.2\MODULES\INSTALL\ASTERSTUDY\RELEASE\ASTERSTUDY_INSTALL\lib\python3.6\site-packages\salome\ASTERSTUDYGUI.py”, line 69, in activate
    return get_aster_gui().activate()

    File “C:\sm-2019-w64-1.2\MODULES\INSTALL\ASTERSTUDY\RELEASE\ASTERSTUDY_INSTALL\lib\python3.6\site-packages\asterstudy\gui\salomegui.py”, line 1067, in activate
    self.work_space = self._createWorkspace(self.main_window)

    File “C:\sm-2019-w64-1.2\MODULES\INSTALL\ASTERSTUDY\RELEASE\ASTERSTUDY_INSTALL\lib\python3.6\site-packages\asterstudy\gui\astergui.py”, line 1593, in _createWorkspace
    work_space = Workspace(self, parent_widget, tab_position(tbposition))

    File “C:\sm-2019-w64-1.2\MODULES\INSTALL\ASTERSTUDY\RELEASE\ASTERSTUDY_INSTALL\lib\python3.6\site-packages\asterstudy\gui\workspace.py”, line 229, in __init__
    self.views[Context.RunPanel] = RunPanel(astergui, self.history_lsplitter)

    File “C:\sm-2019-w64-1.2\MODULES\INSTALL\ASTERSTUDY\RELEASE\ASTERSTUDY_INSTALL\lib\python3.6\site-packages\asterstudy\gui\runpanel.py”, line 451, in __init__
    self._serverActivated()

    File “C:\sm-2019-w64-1.2\MODULES\INSTALL\ASTERSTUDY\RELEASE\ASTERSTUDY_INSTALL\lib\python3.6\site-packages\asterstudy\gui\runpanel.py”, line 1067, in _serverActivated
    self._updateServerInfo(False)

    File “C:\sm-2019-w64-1.2\MODULES\INSTALL\ASTERSTUDY\RELEASE\ASTERSTUDY_INSTALL\lib\python3.6\site-packages\asterstudy\gui\runpanel.py”, line 1085, in _updateServerInfo
    self._infos.refresh_once(self.server(), force)

    File “C:\sm-2019-w64-1.2\MODULES\INSTALL\ASTERSTUDY\RELEASE\ASTERSTUDY_INSTALL\lib\python3.6\site-packages\asterstudy\datamodel\engine\abstract_runner.py”, line 307, in refresh_once
    if self.refresh_one(server):

    File “C:\sm-2019-w64-1.2\MODULES\INSTALL\ASTERSTUDY\RELEASE\ASTERSTUDY_INSTALL\lib\python3.6\site-packages\asterstudy\datamodel\engine\salome_runner.py”, line 562, in refresh_one
    rcdef = self._set_rcdef(server)

    File “C:\sm-2019-w64-1.2\MODULES\INSTALL\ASTERSTUDY\RELEASE\ASTERSTUDY_INSTALL\lib\python3.6\site-packages\asterstudy\datamodel\engine\salome_runner.py”, line 462, in _set_rcdef
    rcdef = rc_manager.GetResourceDefinition(server)

    File “C:\sm-2019-w64-1.2\MODULES\INSTALL\KERNEL\RELEASE\KERNEL_INSTALL\bin\salome\SALOME_ResourcesManager_idl.py”, line 168, in GetResourceDefinition
    return self._obj.invoke(“GetResourceDefinition”, _0_Engines.ResourcesManager._d_GetResourceDefinition, args)

    Like

      1. Below user profile means inside user profile directory? If so I can’t, I have MS account on all my Windows machines wich have space in name. That’s what should be avoided.

        I tried on 3 different computers running Windows 10 20H2. Two of them were with MS account, one without. All Dell’s machines ant the result is the same. Upon activation of AsterStudy module i get unexpected error with no info in command prompt. When I manually close Salome-Meca there appears an info in command prompt:

        This application failed to start because it could not find or load the Qt platform plugin “windows”
        in “”.

        Reinstalling the application may fix this problem.

        I’m using Windows Firewall and Windows built-in antivirus. Unfortunately I have no programming skills. Please help.

        Like

      2. The thing is when SM2019 is directly in C:\ AsterStudy don’t start. When it is in downloads folder on the same computer, but on my Wife’s local account it starts… Although I’m able to run the module, nothing is being calculated when I try run forma02a testcase folowwing 100% instructions form this blog.

        Like

      3. from command prompt:
        C:\Users\Anetka\AppData\Local\Temp\asterstudy_workdir_Anetka\Anetka-Stacja-sob.-13-160814.065\logs\stderr_command_salome.log
        1 file(s) copied.
        3-16:08:13.945 saving case 37-RunCase_1…
        AsterStudy: sob.-13-16:08:13.969 saving case 2-CurrentCase…
        AsterStudy: sob.-13-16:08:14.067 Submitting job on localhost…
        AsterStudy: sob.-13-16:08:14.170 job submitted
        AsterStudy: sob.-13-16:08:14.173 Getting job output on Stacja…
        AsterStudy: sob.-13-16:08:14.276 Getting job output on Stacja…
        AsterStudy: sob.-13-16:08:14.307 Getting job output on Stacja…
        AsterStudy: sob.-13-16:08:14.335 Getting job output on Stacja…
        C:\SMW2019\PRODUCTS\python-3.6.0\Lib\subprocess.py:761: ResourceWarning: subprocess 19936 is still running
        ResourceWarning, source=self)
        This application failed to start because it could not find or load the Qt platform plugin “windows”
        in “”.

        Reinstalling the application may fix this problem.

        Like

  3. Hello I’ve tried Salome-Meca on numerous Windows machines, but the same error appears every time I’m trying to save results to file using “IMPR_RESU”. The computation just fails. But if I run simulation without saving results to file no problem…
    May I ask what’s the problem?

    C:\Users\UNIVER~1\AppData\Local\Temp\asterstudy_workdir_universal\universal-Miami-Ăşt-22-080116.748\logs\*
    The system cannot find such file.
    0 file(s) copied.

    Like

    1. Hello Honza,
      I think there are special character in this path “Ăş” sometime Code_Aster or Salome fail because of special character. To avoid that you should not have special characters in your username, machinename, Idon’t remember you may have a look to the FAQ

      Like

Leave a Reply to Maximilien Siavelis Cancel reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s